javaplugin_oji.so

"Aladino -_-o(L'inventore della faccina col fumetto)" geniodelmale a hotpop.com
Sab 1 Maggio 2004 12:04:39 UTC


Qualche giorno fa, forse a seguito di un aggiornamento poco felice, ho 
iniziato ad avere dei problemi con la posta.
Mozilla si connetteva al server, mi avvisava che c'erano N messaggi da 
scaricare ed effettuava il download. O meglio ci provava: infatti la 
maggior parte delle volte s'incartava, oppure, nella migliore dell 
prospettiva impiegava mezz'ora per scaricare un messaggio.
Dopo vari tentativi infruttuosi di sistemare questo problema (controlla 
la rete, sistema i cavi, checkka la connessione et similia) mi sono 
accort di uno strano messaggio d'errore che campeggiava in console 
quando lanciavo mozilla come client di posta. Messaggio che ora vado a 
riportarvi:

LoadPlugin: failed to initialize shared library 
/usr/lib/j2se/1.3/jre/plugin/i386/mozilla/javaplugin_oji.so 
[/usr/lib/j2se/1.3/jre/plugin/i386/mozilla/javaplugin_oji.so: undefined 
symbol: __vt_17nsGetServiceByCID]

Stando a quel che ho capito da una ricerca fatta in rete e da qualche 
domanda posta in giro il problema dovrebbe risiedere in java, che non e' 
sufficientemente aggiornato (in particolare questo fantomatico javaplugin).
Ordunque ho provveduto ad aggiornare, reinstallare e upgradare tutto 
quello che mi sembrava poter essere correlato al plugin: jre jdk j2se e 
mozilla stesso.
Nulla di fatto il problema persisteva.
Come soluzione _temporanea_ (si spera) ho seguito un consiglio fornitomi 
ed ho rinominato /usr/lib/j2se/1.3/jre/plugin/i386/mozilla/ in 
/usr/lib/j2se/1.3/jre/plugin/i386/mozilla.backup/
in modo da non fargli trovare il plug-in ed in effetti sembra andare un 
po' meglio.
La mia versione di Mozilla e' la 1.5 mentre per la JVM e tutto il resto 
ho scaricato quella di Blackdown ed e' la 1.3.1.
A questo proposito una domanda per i debianisti.
Nel surce.list ho le seguenti righe per indicare il repository di Blackdown:

deb 
ftp://metalab.unc.edu/pub/linuxe/devel/lang/java/blackdown.org/debian 
testing main non-free
deb ftp://ftp.tux.org/pub/java/debian/ testing main non-free

Sono quelli che avete anche voi? per avere una jvm piu' recente e' il 
caso di cambiare magari passando ad unstable? (mi sembra sia l'unico 
modo) Ma csi' facendo non si vengono a creare dei coasini?

grazie a chiunque mi rispondera'

by aL

-- 
Un muro che guarda un uomo
rimane un muro.
Due muri che guardano un uomo
sono il principio di una prigione.

Un uomo che guarda un muro
rimane un uomo.
Due uomini che guardano un muro
sono il principio di un'evasione.



More information about the Talking mailing list